KaedeRPG 導入ガイド
この説明書は KaedeRPG 0.1.0(2026-10-21)のものです。
Unreal Engine の中で、2D の RPG とノベルゲームを作るプラグインです。このガイドは、買ってから見本のゲームを書き出すまでの手順です。

目次
1. はじめての一本道(買ってから書き出すまで)
UE(Unreal Engine)を初めて使う人が、KaedeRPG を買ってから見本のゲームを書き出すまでの順番です。上から順に進めれば、ほかの章もリファレンスも読まずに最後まで行けます。ほかの章とリファレンスは、自分の作品を作るときに、必要な所だけ読んでください。
先に全体の順番です。 KaedeRPG は単独で起動するアプリではなく、UE のエディタの中で動く道具です。なので「KaedeRPG を起動する」という手順はありません。UE でプロジェクトを開き、メニューからツールを開きます(1.7)。このガイドとリファレンスでは、プログラムを立ち上げることを「起動する」(ランチャー・UE・書き出したゲーム)、動いているプログラムの中で窓や作品を出すことを「開く」(プロジェクト・RPG 制作ツール・見本)と書き分けます。UE の公式の文書と同じ使い方です。
| 順 | やること | どこで | 終わると |
|---|---|---|---|
| 1.1 | Fab で KaedeRPG を買う | Fab | ランチャーのライブラリに KaedeRPG が入る |
| 1.2 | UE 5.8 を入れる | Epic Games Launcher | UE を起動できる |
| 1.3 | 買った KaedeRPG をエンジンに入れる | ランチャー | UE に KaedeRPG が入る |
| 1.4 | 無料のプラグイン 2 つを足して、エンジンに入れる | Fab とランチャー | UE に KaedeVN と MomijiUI が入る |
| 1.5 | Visual Studio を入れる | Microsoft のインストーラー | 書き出しの準備が整う |
| 1.6 | 新しいプロジェクトを作る | UE のプロジェクトブラウザ | 自分のプロジェクトがエディタで開く |
| 1.7 | プロジェクトで KaedeRPG を有効にし、ツール → KaedeRPG で開く | UE のエディタ | RPG 制作ツールの窓が出る |
| 1.8 | 見本を開く | RPG 制作ツール | 見本の作品が読み込まれる |
| 1.9 | テストプレイ | RPG 制作ツール | 別の窓で見本を遊べる |
| 1.10 | 書き出しの準備をして、UE でパッケージ化 | RPG 制作ツールと UE | Windows の exe ができる |
2 回目からは、1.6 で作ったプロジェクトを開き、1.7 の手順 3(ツール → KaedeRPG)だけを行います。1.1〜1.5 と 1.7 の手順 1・2 は最初の 1 回だけです。
1.1 Fab で KaedeRPG を買う
- Epic Games のサイトで、Epic Games のアカウントを作ります。
- Fab(fab.com)にそのアカウントでサインインし、KaedeRPG のページで買います。買うと、同じアカウントの Epic Games Launcher のライブラリに KaedeRPG が入ります。
1.2 Unreal Engine を入れる
- Epic Games のサイトから Epic Games Launcher(ランチャー)を入れ、1.1 のアカウントでサインインします。
- ランチャーの Unreal Engine → ライブラリ で、エンジンのバージョンの + を押し、5.8 を選んで インストール します。
1.3 買った KaedeRPG をエンジンに入れる
- ランチャーの Unreal Engine → ライブラリ を開くと、Fab の欄に 1.1 で買った KaedeRPG が並んでいます。
- KaedeRPG の エンジンにインストール を押し、5.8 を選びます。プラグインは
<UE のフォルダ>\Engine\Plugins\Marketplace\の下に入ります(UE のフォルダの既定はC:\Program Files\Epic Games\UE_5.8。フォルダの名前の後ろに版が付くことがあります)。
1.4 無料のプラグインを 2 つ足す
KaedeRPG が動くには、無料のプラグインが 2 つ要ります。KaedeVN(ノベルの部分)と MomijiUI(画面の部分)です。KaedeRPG だけでは動きません。
- Fab で KaedeVN のページを開き、「ライブラリに追加」します。MomijiUI も同じようにします。どちらも無料です。
- ランチャーの Unreal Engine → ライブラリ の Fab の欄に 2 つが並びます。それぞれ エンジンにインストール を押し、5.8 を選びます。1.3 と同じ場所に入ります。
1.5 Visual Studio を入れる(.vsconfig)
ゲームとして書き出すとき、このプラグインのコードを組み立てるために Visual Studio が要ります。書き出す直前でなく、いま入れておきます。入っていないと、1.10 で書き出しの準備のあとにエディタを開き直すところで止まります。
- Microsoft のサイトから Visual Studio Community(無料。2026、または 2022 の 17.8 以降)のインストーラーを取ってきて起動すると、Visual Studio Installer が開きます。
- Visual Studio Installer の その他 → 構成のインポート(英語の表示では More → Import configuration)で、KaedeRPG のプラグインのフォルダ(1.3 の置き場)にある
.vsconfigを選び、インストール します。UE 5.8 が勧める部品(C++ によるデスクトップ開発・C++ によるゲーム開発・Windows 11 SDK など)に、まとめて印が付きます。
1.6 新しいプロジェクトを作る
- ランチャーの Unreal Engine → ライブラリ で、5.8 の 起動 を押します。
- プロジェクトブラウザで ゲーム → 空のプロジェクト(Blank)を選び、ブループリント のままにします(C++ を選ばなくてよい。書き出しに要る C++ は、あとで 書き出しの準備… が足します)。
- プロジェクトの名前は英数字と
_だけ(例MyRpg)にして 作成 を押します。日本語や空白の入った名前は、書き出しの準備で断られます。
これで、新しいプロジェクトがエディタで開きます。
1.7 プロジェクトで KaedeRPG を有効にして、ツールを開く
プラグインはエンジンに入っただけでは使えず、プロジェクトごとに有効にします。有効にするのは、プロジェクトを作った最初の 1 回だけです。
- エディタの 編集 → プラグイン で KaedeRPG を探し、印を付けて有効にします。KaedeRPG に要る KaedeVN と MomijiUI も有効にするかを聞く窓が出るので、はい を押します。
- 「再起動が必要」と出るので、エディタを開き直します。同じプロジェクトを開きます。
- メニュー ツール → KaedeRPG(RPG 制作ツール) を選びます。RPG 制作ツールが独立した窓で開きます。これが KaedeRPG を開く操作で、以後は毎回この操作で開きます。UE のタブとして作ってあるので、好みでメインの窓にドッキングもできます。
2 回目からは、ランチャーの Unreal Engine → ライブラリ で 5.8 を 起動 し、プロジェクトブラウザの「最近使ったプロジェクト」から 1.6 のプロジェクトを開いて、手順 3 だけを行います。
プラグインのフォルダの Build-KaedeRpgCli.bat は、CLI(リファレンスの §14)を自分で組み立てるときだけ使います。エディタだけで作るなら飛ばしてかまいません。
1.8 見本を開く
- ツールの 見本を開く を押します。見本の作品がプロジェクトの
Works\sample_questへ写され、開きます(マップ・イベント・データベースが読み込まれます)。
1.9 テストプレイ
- ツールの ▶ テストプレイ を押すと、別の窓で見本のゲーム「ねずみ退治」が始まります。矢印キーで歩き、Enter で話しかける・文を送る、Esc でメニューです(始まりに主人公の名前を聞かれたら、打って Enter)。ほかのキーとゲームパッドは、リファレンスの §12「ゲームの操作」にあります(書き出しには要りません)。
- 遊んでいる間に F9 を押すと、デバッグの窓が開きます(変数・所持品・お金を変える・壁抜け・この戦闘に勝つ など。このガイドの §6)。もう一度 F9 で閉じます。遊び終えたら、テストプレイの窓を閉じて次へ進みます。
1.10 書き出す(パッケージ化)
- 1.5 の Visual Studio が入っていることを確かめます。Windows のスタートメニューに Visual Studio 2022 か 2026 があれば入っています。入っていない状態で進むと、手順 4 でエディタを開き直すところで止まります。
- ツールの窓の上に出ている検査の件数で、error が 0 件なのを確かめます。
- ツールの 書き出しの準備… を押し、出た確かめの窓で書き込みます。
- エディタを開き直します。モジュールを組み立て直すかを聞く窓が出るので、はい を押します。ここで Visual Studio がコードを組み立てます。
- UE の プラットフォーム → Windows → プロジェクトをパッケージ化 で、出力先のフォルダを選びます。
- 出来たフォルダの exe を起動すると、見本のタイトル画面から始まります。
自分の作品は、ツールの 新規… で作り(新規は見本から始めるのが既定。リファレンスの §2「作品フォルダ」)、1.9・1.10 と同じ順で遊んで書き出します。1 つのプロジェクトで書き出せるのは、最後に 書き出しの準備… を押した作品 1 つです。別のゲームは別のプロジェクトで作ってください。詳しくは §7。
2. このプラグインでできること
| 分野 | できること |
|---|---|
| マップ | 48px のタイルで、下・中・上の 3 層を塗る。通行(○×と上書き)。イベントを置く。プレイヤーの開始位置。雰囲気(暗さと明かり・霧・雨と雪・遠景・前景)・カメラのズームと寄せ |
| イベント | ページ(出現条件・見た目・起動・高さ・自律移動・明かり)と、命令の列(会話・フキダシ・止まらない会話・選択肢・条件分岐・変数・移動・戦闘・ショップ・音・演出・アニメ・天候・カメラ・クレジット・クエスト・合成の画面・エンカウント・ピクチャ・入力など 60 種) |
| ノベル | 物語の話(章と話)。背景・立ち絵(表情)・顔・名前・文字送り・文字の音・文中の差し込み(変数・アイテム名など)と本文の色・オート・既読スキップ・バックログ・演出(揺れ・フィルタ・暗転) |
| 戦闘 | 正面型のコマンド戦闘(たたかう・技・アイテム・防御・逃げる)。計算式を自分で書ける。状態異常・落とす物・経験値とレベル。技と攻撃のアニメ・勝利の画面。運で決まるもの(ダメージの振れ・命中・敵の行動・エンカウント)は全部 1 つの乱数の種(乱数の出発点になる数)から引くので、同じ種なら必ず同じ結果(決定論。リファレンス §14 の play・battle の --seed) |
| データベース | 作品の設定・仲間・技・アイテム・敵・敵の組・状態・クエスト・合成・システム・サーバー |
| 画面 | 起動のロゴ・タイトル・メニュー・所持品・技・装備・状態・セーブ/ロード(20 枠+オート)・設定(音量 4 系統・文字の速さなど)・ショップ・ゲームオーバー・バックログ・勝利の画面・マップの HUD と入手のお知らせ・クレジット。配置・色・書体は画面のタブで見ながら変えられる(リファレンス §10) |
| 検査 | 「最後まで遊べるか」を機械で確かめる(行けない場所・終わらない自動イベント・満たせない条件・勝てない最初の戦闘・呼ばれないエンディングなど) |
| 生成 AI | 作品フォルダで Claude Code・Codex に頼むと、同梱の CLI(コマンドラインツール kaede-rpg.exe。クリックの代わりに Windows の PowerShell に命令を打って使う道具。リファレンス §14)とスキルで作品を直す。書くたびに自動で検査 |
| 書き出し | ボタン 1 つでプロジェクトの設定を整え、UE の「パッケージ化」でゲームにする(Windows) |
作品は作品フォルダの JSON(文字のファイル)です。エディタ・CLI・生成 AI の、どれで直しても同じ結果になります。Git で差分を見られます。
3. 要るもの
- Unreal Engine 5.8・Windows(64 bit)
- ゲームとして書き出すとき: Visual Studio 2022(17.8 以降)か 2026。このプラグインのコードをゲームに組み込むために要ります。要る部品は、プラグインに同梱の
.vsconfigで入れます(§1.5) - CLI を自分で組み立てるときだけ: 上の Visual Studio と CMake 3.20 以降(組み立て済みの
ThirdParty/Win64/kaede-rpg.exeが同梱されているので、ふつうは要りません。組み立てるとBinaries/Win64/kaede-rpg.exeができます)
4. 入れる・開く
ふつうは §1.3〜§1.7 の手順(Fab からエンジンに入れ、プロジェクトで有効にして、ツール → KaedeRPG で開く)で入れます。ここには、それ以外の入れ方だけを書きます。
- プロジェクトに入れる: エンジンでなく 1 つのプロジェクトだけに入れるときは、プラグインのフォルダをプロジェクトの
Plugins/KaedeRPG/に置きます(依存する無料のプラグイン KaedeVN と MomijiUI も同じPlugins/の下に)。そのあとは §1.7 と同じです。 - 自分の作品を作る: ツールの 新規… で作ります。新規は見本から始めるのが既定です(見本のマップ・データベース・素材を写して、自分の作品に直していきます。リファレンス §2)。
- CLI が無いとき: CLI(
ThirdParty/Win64/kaede-rpg.exe)が無いときは、プラグインのフォルダのBuild-KaedeRpgCli.batをダブルクリックすると組み立てます。エディタだけで作るなら要りません。
5. 見本の作品を遊ぶ
プラグインには、短い見本の作品「ねずみ退治」が入っています。村の長老に頼まれ、洞窟のねずみの王を倒す RPG です(10 分ほど)。
- RPG 制作ツールで 見本を開く を押します。見本がプロジェクトの
Works/sample_questへ写され、開きます(写し元はプラグインのResources/Rpg/Samples/sample_quest。プラグインのフォルダを探さなくてかまいません)。もう写してあれば、写し直さずにそれを開きます。 - ▶ テストプレイ を押すと、別の窓で遊べます。始まりに主人公の名前を付けます(文字欄に打って Enter か 決定。日本語は IME で打てます。やめる と「ユウ」のまま)。名前は地の文と長老の台詞に出ます。
| 始まりの話 | 村 | 長老に話しかける |
|---|---|---|
![]() |
![]() |
![]() |
| 洞窟 | 戦闘 | エンディング |
|---|---|---|
![]() |
![]() |
![]() |
ねずみの王を倒したあと、長老の机(長老の右上。長老と話す所の右)を調べると、お礼の手紙が絵(ピクチャ・リファレンス §5)で出ます。
見本の作品の中身(マップ・イベント・データベース)をエディタで開いて読むと、作り方の例になります。
英語で遊ぶ: 見本の rpg.json に "language": "en" を書くと(データベースのタブの作品の設定の ゲームの画面の言語)、タイトル・メニュー・戦闘の文・入手のお知らせが英語になります(リファレンス §2 の「作品の言語」)。見本の台詞と名前は作品が書いたものなので日本語のままです。
6. テストプレイ
- ▶ テストプレイ: 保存してから、別の窓で始めから遊びます。
- マップの右クリック ここからテストプレイ: そのマスから始めます。
- テストプレイ中に F9 で デバッグの窓: 変数(真偽は切り替え・数は ±1)・所持品(±1)・お金(±100)を変える、壁抜け、エンカウントなし、歩く速さ(1・2・4 倍)、戦闘中なら この戦闘に勝つ(報酬は配る)。もう一度 F9 か × で閉じます。書き出したゲームでは開きません。
- 設定の画面の 全画面(Alt+Enter でも切り替わる)と 窓の大きさ(1280×720・1920×1080・2560×1440)は
settings.jsonに書かれ、書き出したゲームでは次に起動しても同じです。 - テストプレイの窓は、設定を変えたときに 窓の大きさだけ 変わり(開いたときはいつもの大きさ)、全画面にはなりません(設定の画面に「書き出したゲームで効く」と出ます)。全画面は書き出したゲームで効きます。
7. 書き出す(ゲームにする)
先に Visual Studio を入れておきます(§1.5)。
- 検査に error が無いことを確かめます。
- ツールの 書き出しの準備… を押します(確かめの窓が出ます。何度押してもかまいません)。
- エディタを開き直します(モジュールを組み立て直すかを聞かれたら はい)。
- UE の プラットフォーム → Windows → プロジェクトをパッケージ化 で書き出します。売るときは、パッケージ化の構成を Shipping(配る版)にします(試すだけなら Development でも動きます)。
書き出したゲームは、タイトル画面から始まります。作品フォルダはゲームの中に、ファイルのまま入ります。
自分のゲームを売るときの UE の取り決め(売上が生涯 100 万ドルを超えた分のロイヤリティなど)は、利用者と Epic Games の間のものです。Epic の EULA を確かめてください。
7.1 書き出しの準備がすること
自分で書く必要はありません。ボタンがプロジェクトの設定に次を書きます(同じ行は重ねません)。
DefaultGame.ini: 作品フォルダを同梱する行と、作品フォルダの場所(1 つのプロジェクトで 1 作品。別の作品で押し直すと、起動する作品がそちらに替わります)DefaultEngine.ini: ゲームインスタンス(KaedeRpgGameInstance)と起動レベル(エンジンの空のレベル)- 起動中の絵(
Content/Splash/Splash.bmp)。ゲームの起動中に小さな窓で出ます。もう置いてあれば上書きしません。自分の絵にするときは、同じ名前の BMP に置き換えてください - プロジェクトに C++ が無ければ、最小のゲームモジュール(
Source/の 4 ファイル)と.uprojectの設定。C++ の無いプロジェクトは、書き出しで UE 既成のゲームの exe を使い、このプラグインのコードが入らないためです。足したあと開き直すと組み立てが走ります(Visual Studio が要ります)
8. 困ったとき
| こんなとき | 見るところ |
|---|---|
| メニューに「KaedeRPG(RPG 制作ツール)」が無い | プラグインが有効か(編集 → プラグイン)。有効にしたらエディタを開き直す |
Visual Studio Installer で .vsconfig を選べない |
ワークロードの C++ によるデスクトップ開発 と C++ によるゲーム開発 に印を付けて入れる(要る部品の中心はこの 2 つ。§1.5) |
| 「作品フォルダでない」と出る | rpg.json のあるフォルダを選んでいるか |
| 書き出しの準備で「プロジェクトの中に置く」と出る | 作品フォルダをプロジェクトのフォルダの下へ写して開き直す |
| 書き出しの準備で「プロジェクトの名前が C++ の名前に使えない」と出る | プロジェクトの名前を英数字と _ だけにする(新しいプロジェクトを英数字の名前で作り直し、作品フォルダを写す。§1.6) |
| 書き出したゲームがすぐ終わる・「モジュールが無い」 | 書き出しの準備のあと、エディタを開き直して組み立てたか(Visual Studio が要る。§1.5) |
| 検査が error を出す | 検査のタブで行をダブルクリックして、その場所の「直し方」を見る |
| AI が書いたのにエディタが変わらない | 未保存の変更があると自動では読み直さない。上の「読み直す」を押す |





